Jump to content
Accelerated Evolution
Sign in to follow this  
Alundra

WoW Lag after latest patch.

Recommended Posts

Maybe I am alone here at AE, but there are about 300+ people (including myself) that I have encountered on the Blizzard forums that are having the same issue: extreme lag since last patch.

I used to have a comfortable latency of 50-150 at any given time on any given day, but now,. I just hit 13,000 latency (got the screen to prove it), and was promptly logged off of my server. This is an issue that has been torturing me over the past week, because I recently started Faiyn and Quartz to play Mercury Shadow, and now I can't even group with anytone because I lag out or just stand still due to lag.

My comp specs are above average, and I went out and bought a superior network card to replace my Linksys Speedbooster Wireless G USB adapter, which would be the same Linksys product in card form. I now sport "Excellent" signal strength as opposed to my "Low" and "Very Low" strength with the USB adapter. Even with the significant increase in signal strength, I have seen even worse lag come of the situation.

I have called Linksys, and they said it was the router, I called the router company, they said it was the game, I called Blizzard, they said it was my ISP, I called my ISP, and they said they would send someone out to check the trace route problem on Tuesday. So if the ISP cannot fix the problem, I am forced to either quit WoW and cancel my account (which I really don't want to do), or try and play at 4-10AM weekdays when the servers are at low capacity so I can pull at least 500 latency.

The threads in the Blizzard forums are being ignored by Blue, so I am wondering, have any of you had a similar problem?

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...